Amavis not being called from postfix

Patrick Ben Koetter p at
Fri Feb 8 18:02:00 CET 2019


* Robert Moskowitz <rgm at>:
> The system is CentOS7.
> My and reflect

please send output from these commands to the list:

$ postconf smtpd_milters content_filter smtpd_proxy_filter
$ postconf -Mxf

How did you configure amavis to receive mail from Postfix? Does it provide an
SMTP/LMTP server on port 10024? Do you want it to receive messages via MILTER?

> When I run the test message from
> /usr/share/doc/amavisd-new-2.11.1/test-messages
> as
> sendmail -i rgm at < sample-virus-simple.txt
> all I see in maillog is
> Feb  8 11:11:45 klovia postfix/pickup[14472]: 3DD4059DA: uid=0 from=<root>
> Feb  8 11:11:45 klovia postfix/cleanup[14478]: 3DD4059DA:
> message-id=<20190208161145.3DD4059DA at>
> Feb  8 11:11:45 klovia postfix/qmgr[14473]: 3DD4059DA:
> from=<root at>, size=430, nrcpt=1 (queue active)
> Feb  8 11:11:45 klovia dovecot: lda(rgm at sieve:
> msgid=<20190208161145.3DD4059DA at>: stored mail into
> mailbox 'INBOX'
> Feb  8 11:11:45 klovia postfix/pipe[14484]: 3DD4059DA:
> to=<rgm at>, relay=dovecot, delay=1.1,
> delays=0.8/0.05/0/0.22, dsn=2.0.0, status=sent (delivered via dovecot
> service)
> Feb  8 11:11:45 klovia postfix/qmgr[14473]: 3DD4059DA: removed
> I can't seem to find why amavis is not being called.  HOw do I get debug
> turned on?  I have tried adding -v to the smtpd lines in and no
> change.  Where do I look to get this working?

Once I have a better idea which setup you want and which you have actually
configured (see commands above) I will help you do debug.

p at rick

[*] sys4 AG, +49 (89) 30 90 46 64
Schleißheimer Straße 26/MG,80333 München
Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
Vorstand: Patrick Ben Koetter, Marc Schiffbauer, Wolfgang Stief
Aufsichtsratsvorsitzender: Florian Kirstein

More information about the amavis-users mailing list