"No SMTP response to data-dot"-message and delivered the message like 10 times

Michael Meier crap at rmm.li
Tue Apr 11 11:52:16 CEST 2017

On 10.04.2017 09:32, Tilman Schmidt wrote:
> On 07.04.2017 20:52, Michael Meier wrote:
>> When sending the mail it seems as it slowly uses up to 150mb more than
>> before. I noticed, that the load stays really high, even after
>> thunderbird said that the message was sent (took several minutes). Then
>> the load stays high for another few minutes until in the logfile I get
>> the message:
>> Apr  7 20:19:50 rmm amavis[9269]: (09269-01) Passed CLEAN
>> {RelayedInbound}, []:52590 []
>> <user at example.com> -> <user at example.com>, Queue-ID: B865B2E1987,
>> Message-ID: <03f80e77-0a8b-6c63-e2e5-23c4d02bc404 at example.com>, mail_id:
>> QWkNkUIuIFIu, Hits: -2.79, size: 15512628, queued_as: D90372E19B6, 323647 ms
>> Then the cpu load drops immediately and I finally can get the sent mail
>> over imap.
> 323647 ms are five minutes. Thas is much too long for processing a mail.
> It causes the sender to time out and try again, resulting in the
> behaviour you observe.
> You should investigate what is causing that enormous delay. As a guess,
> are you using ClamAV's non-daemonized command line, clamscan? That might
> explain it. It is quite inefficient since it will load the entire
> signature database into memory for every single mail only to drop it
> afterwards. Try switching to clamd/clamdscan.

unfortunately I already use clamd. I also tried to  deactivate the virus
scanning in amavis, but it still behaves exactly the same...

so now I tried sending an e-mail using
amavisd-new debug

I tried to attach the logfile, but since it is too long the mailing list
didn't accept it, so I put it here:


As it seems most of the time do those rw_loop need. Which seem to be
really slow for copying only really small amounts of data. (as i said,
the cpu load of the server goes really high, while his doing that)
In the statistic at the end it states:
fwd-data-contents: 183500 (64%)66, fwd-end-chkpnt: 98332 (34%)100,

anybody got an idea what I could check to find out what the exact
problem is?

More information about the amavis-users mailing list