"No SMTP response to data-dot"-message and delivered the message like 10 times

Tilman Schmidt tschmidt at cardtech.de
Tue Apr 11 17:52:33 CEST 2017

On 11.04.2017 11:52, Michael Meier wrote:
> so now I tried sending an e-mail using
> amavisd-new debug
> I tried to attach the logfile, but since it is too long the mailing list
> didn't accept it, so I put it here:
> https://rmm.li/cloud/index.php/s/jjVaWM6MOM0UtdP
> As it seems most of the time do those rw_loop need. Which seem to be
> really slow for copying only really small amounts of data. (as i said,
> the cpu load of the server goes really high, while his doing that)
> In the statistic at the end it states:
> fwd-data-contents: 183500 (64%)66, fwd-end-chkpnt: 98332 (34%)100,
> anybody got an idea what I could check to find out what the exact
> problem is?

That log spans half an hour and looks like it contains several mail
transmissions. I would start by paring it down to a single mail
transaction that took too long.

Also watch "top" in a second window during the test to see which process
is causing the CPU load.

And third, it looks like the delay is happening when Amavis is
forwarding the mail to the MTA on localhost:10025 so you should check
your Postfix log, too, correlating it with the Amavis log.


Tilman Schmidt
Card & POS Service GmbH
Richard-Byrd-Straße 37
50829 Köln

More information about the amavis-users mailing list