Net::Server failure ?

via amavis-users amavis-users at
Fri Nov 22 05:49:50 CET 2013

On Fri, November 22, 2013 1:31 am, tejas sarade wrote:
> It seems like the issue with Perl modules. Something is causing to pass
> undef value to perl-Net-Server. May be some Perl expert will figure out
> exactly what is happening.

I hope so..

> What version of perl-Net-Server you are using?

not sure how to query, if I try to install, I get 2.007

install Net::Server
CPAN: Storable loaded ok (v2.45)
Reading '/root/.cpan/Metadata'
  Database was generated on Thu, 21 Nov 2013 05:17:02 GMT
CPAN: Module::CoreList loaded ok (v2.18)
Net::Server is up to date (2.007).

# perl --version

This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi

> I am using following versions on CentOS 6
> perl-Net-Server-0.97-7.el6.noarch amavisd-new-2.8.0-4.el6.noarch
> Note that I have installed amavis from EPEL(
> repository which includes
> all the dependencies for amavis. And everything is working fine.
> Just cross check the Perl modules, when right version is not installed
> they tend to break the things.

I've tried (re)installing all amavis pre-req perl modules, most were up to

original amavis install came with Postfix/dovecot preinstalled as part of
'iredmail' mail server setup

it run OK for around two weeks, with very few users, I definitely tried
'amavisd debug' with initial install as I wanted to check

yesterday, I've attempted to re-install all Perl modules as listed in
amavis pre-req, and, d/l new amavis from amavis home page # amavisd -V
amavisd-new-2.8.1 (20130628)


More information about the amavis-users mailing list