Problem with spam quarantine

Nikolaos Milas nmilas at
Thu Aug 30 23:41:10 CEST 2012

On 30/8/2012 9:05 μμ, Nikolaos Milas wrote:

> Hmmm, that's exactly the command I issued as well (see above), but it 
> caused an error!
> So, what may the cause be? 

An update:

As I was using amavisd-new-2.4.5-1.el5.noarch from the EPEL repo, I 
thought I could try to upgrade to amavisd-new.x86_64.2.6.6-3.el5.rf 
available at rpmforge repo. This caused me a whole lot of new problems 
because the two RPMs were in fact totally different in their structure 
(paths, config files, init scripts, etc.) but in the end *it seemed* it 
worked and the release command gave this strange result (because there 
were recipients indeed)!

[root at mailgw2 spam]# /usr/sbin/amavisd-release 
250 2.5.0 No recipients, nothing to do

In any case, as I had modified various stuff which should not remain in 
such condition (so the above may not be a truly representative result), 
I decided and returned back to the original amavisd-new RPM and things 
run as before.

Finally, as a test, I decided to set:
     $spam_quarantine_method = "local:spam/%n-%m" ;
rather than:
     $spam_quarantine_method = "local:spam/%n-%m-%i" ;

And, to my (happy) surprise, this time it worked:

Aug 31 00:30:43 mailgw2 amavis[2792]: (02792-01) Blocked SPAM, 
[] [] <nick at> -> 
<nmilas at>, quarantine: spam/02792-01-bzM11CH7LOH8, 
Message-ID: <503FDB76.9020608 at>, mail_id: bzM11CH7LOH8, 
Hits: 999.999, 2446 ms

[root at mailgw2 ~]# amavisd-release spam/02792-01-bzM11CH7LOH8
250 2.6.0 Ok, id=rel-bzM11CH7LOH8, from MTA([]:10025): 250 
2.0.0 Ok: queued as 77B862F888B

...which was delivered fine.

So the question now is: Why the format "local:spam/%n-%m-%i" is not 
working right with amavisd-release ?


More information about the amavis-users mailing list