Bug in amavisd-new, or p5-DBD-mysql?

Tom Sommer mail at tomsommer.dk
Mon Sep 17 11:58:49 CEST 2018

On 2018-08-29 17:35, David Newman wrote:
> On 8/27/18 12:40 PM, David Newman wrote:
>> Again answering my own post: After a lot of searching, I found reports
>> of a previously known type-conversion bug in the Perl DBD-MySQL module
>> (aka p5-DBD-mysql on FreeBSD):
>> https://github.com/perl5-dbi/DBD-mysql/issues/78
>> https://lists.amavis.org/pipermail/amavis-users/2016-December/004674.html
> This post claims the problem is with amavisd-new, and not p5-DBD-mysql:
> https://de.postfix.org/pipermail/amavis-users/2017-January/004711.html
> Quoting: "The change is that [as of 4.038] p5-DBD-mysql now returns
> mysql doubles as perl doubles and mysql floats as perl floats (and not
> as a string anymore). This should be adressed [sic] by amavisd."
> In a followup, the maintainer for the Debian port of amavisd-new asks
> for more info to look into a patch, but that was in January 2017 and 
> the
> port is still broken.
> I'm frankly not qualified to answer: Is this an amavisd problem, or a
> p5-DBD-mysql problem? As it is, amavisd-new is getting bad data.

FYI: I just hit this issue when updating DBD::mysql to 4.048, reverting 
to 4.037 solved it for me (no other version worked).


More information about the amavis-users mailing list