Amavis fails to start with "lost connection with"

Alex mysqlstudent at
Wed Dec 23 15:08:45 CET 2015


I have amavisd-new-2.10.1 on fedora22 with perl-5.20 and all updates.
For some reason this morning it just stopped working without anything
having changed at that time.

I've seen this in the past, and have deleted the tmp databases and
it's started again, but not this time. I've tried to increase logging
and it doesn't produce any further information.

The last few lines of the output are:

Dec 23 09:03:28 bwimail01 amavis[3890]: Deleting db files
__db.001,__db.002,__db.003,snmp.db,nanny.db in /var/spool/amavisd/db
Dec 23 09:03:28 bwimail01 amavis[3890]: Creating db in
/var/spool/amavisd/db/; BerkeleyDB 0.55, libdb 5.3
Dec 23 09:03:28 bwimail01 amavis[3890]: initializing Mail::SpamAssassin (0)
Dec 23 09:03:28 bwimail01 amavis[3890]: SpamAssassin debug facilities: info
Dec 23 09:05:02 bwimail01 amavis[3890]: Net::Server:
2015/12/23-09:05:02 Server closing!

When I try to run it as the amavis user from the command-line:

$ /usr/sbin/amavisd -c /etc/amavisd/amavisd.conf foreground
Subroutine inet_any2n redefined at ../../blib/lib/NetAddr/IP/
        (autosplit into
../../blib/lib/auto/NetAddr/IP/InetBase/ line 485 (#1)
    (W redefine) You redefined a subroutine.  To suppress this warning, say

            no warnings 'redefine';
            eval "sub name { ... }";

Subroutine ipv6_aton redefined at ../../blib/lib/NetAddr/IP/
        (autosplit into
../../blib/lib/auto/NetAddr/IP/InetBase/ line 406 (#1)

I'm not sure if that's the expected output, though. I've also tried
"debug-sa" and "debug" and it also just dies at the same spot.

Could this be a perl problem? How can I troubleshoot this? I've got
400 messages in the queue that aren't being delivered, so could really
use some help.


More information about the amavis-users mailing list