Postfix unable to pass messages to amavis ( Can't connect to INET4 socket

Mike Godshall via amavis-users amavis-users at
Mon May 19 04:10:23 CEST 2014

Thanks for looking at it.  The one thing you mention that I have not seen as a recommendation yet is to telnet to the postfix reinjection port at  I have tried that and that is not working which explains why I see the following in the mail logs:

May 18 21:56:58 ubuntu12 postfix/smtp[30938]: 79AFD5F9FD: to=<me at>, relay=[]:10024, delay=883, delays=820/0.01/0/63, dsn=4.4.1, status=deferred (host[] said: 450 4.4.1 id=29970-05 - Temporary MTA failure on relaying, Can't connect to INET4 socket Connection timed out, MTA([]:10025), id=29970-05 (in reply to end of DATA command))

lsof -i tcp:10025
master  30434 root  111u  IPv4 2034261      0t0  TCP ip6-localhost:10025 (LISTEN)
master  30434 root  114u  IPv6 2034265      0t0  TCP ip6-localhost:10025 (LISTEN)

That means postfix is listening on port 10025 no?


On 05/15/2014 07:38 PM, Noel Jones via amavis-users wrote:
> On 5/15/2014 5:46 PM, via amavis-users wrote:
>> I have been trying to get postfix to work with amavis but have been
>> unable. No matter what I have tried I can't get past the following error:
>> [snip] Can't connect to INET4 socket
>> I can successfully run telnet 10024 and amavis answers. I have
>> been trying to have amavis listen on instead thinking that might
>> be the problem since the default localhost address on the machine is
>> Nothing else in the logs to indicate a problem.
> So what *is* in the logs?  Posting random snips doesn't help much.
>> I initially installed using the directions here:
> Showing your actual config rather than "sort of like this random web
> page" would be more helpful.
> Does anyone know how I can further troubleshoot this?
> postconf -n follows:
> What you posted is unreadable due to being all jumbled together.
> And it doesn't show the modifications you made for amavis,
> nor the changes you made to amavis config files.
> Troubleshooting hints:
> - make sure you can telnet to the amavis listener at
> - make sure you can telnet to the postfix reinjection port at
> - make sure your config matches what you intend, especially IP:port
> settings.
> - check the logs for clues about what's wrong.
> - disable SELINUX or other security software
> -  NOTE: verbose logs are *not* required, and will hide errors in a
> flood of irrelevant data.
> There are a lot of moving parts, but it's really not that
> complicated. Check each part in turn.
> If you need to ask for more help, share your setup and full unedited
> NON-VERBOSE log messages.
>    -- Noel Jones

More information about the amavis-users mailing list