Kaspersky KLMS 8.0 and amavis - partial success...

Jakob Curdes jc at info-systems.de
Mon Jun 23 22:47:17 CEST 2014

  hello all,

I have been trying to integrate klms 8.0 into amavisd.  Up to now I 
could not get the client-server version to work, so I tried to use the 
command line scanner "kavscanner".
To run this as user amavis (instead of kluser), I needed to

- adapt the owner and group of the logfile which is by default 
- adapt the owner of the socket file /var/run/klms/facade
- set the user and group amavis instead of kluser in the app control 
file /var/opt/kaspersky/apps/1463

After these changes, I can use the kavscanner from the amavis user when 
doing this on the command line.
However, when called from amavisd, the same command does exit with

  run_av: /opt/kaspersky/klms/bin/kavscanner exit 50, Kaspersky 
Anti-Virus On-Demand Scanner.\nCopyright (C) Kaspersky Lab, 
1997-2012.\n\rLoading bases error(Engine not ready)

which is the same error I get on the command line when the ownership of 
/var/run/klms/facade is not set to user/group amavis.

What is the amavis daemon doing differently from the interactive user? 
How can I find out more about the environment that amavisd creates? I 
already used a test script that dumped me the environment; I did not 
detect anything unusual there. I have the feeling I am missing something 
small, but am not sure what it is.

Jakob Curdes

More information about the amavis-users mailing list