razor problems Can't read conf file: /root/.razor/razor-agent.conf

Deeztek Support via amavis-users amavis-users at amavis.org
Mon Aug 26 18:33:59 CEST 2013

On 8/26/2013 11:36 AM, Benedict White wrote:
>>> I'm getting this error in my amavis logs concerning
>>> >>razor2.
>>> >>
>>> >>razor2: razor2 check failed: No such file or directory razor2: Can't
>>> >>read conf file:/root/.razor/razor-agent.conf at
>>> >>/usr/share/perl5/Mail/SpamAssassin/Plugin/Razor2.pm line 325.
>>> >>
>>> >>The razor-agent.conf file exists in that location so I'm not
>>> >>understanding why it doesn't work.
>>> >>
>>> >>Thanks in advance
>>> >>
>> >Check the file rights with ls -l, then check what user Amavisd, spamassassin and Razor are running under.
>> >
>> >Kind regards
>> >
>> >Benedict White
> The file rights are as follows:
> -rw-r--r-- 1 amavis amavis  706 2010-11-27 14:47 razor-agent.conf
> Amavisd runs as amavis. There is no process for razor from what i can
> tell. I thought amavis called that process wheat n needed. The spamd daemon
> runs as root.
> Firstly this should be posted to the list, under it's own subject,
> Secondly Amavisd doesn't call Razor, Spamassassin does. Have you tried setting
> the ownership as root?
> That said, there are documents on Razor set up which I haven't read for an age
> which cover setup and testing.
1. posted on its own subject
2. Tried setting it as root and got the exact same error
3. Read the docs and here's the extend of the "documentation" on razor:

Install and configure razor:

apt-get install razor
razor-admin -create
razor-admin -register

Running this command to verify razor:

razor-admin -d -debuglevel=9 -create

Generates the following:

razor-admin finished successfully.

so it seems to be installed and configured correctly as far as the 
system is concerned. Amavis seems to complain when I run it in debug mode.

**Now the "documentation" on Ubuntu's website said the following after 
instructing to install razor:

"Spamassassin automatically detects optional components and will use 
them if they are present. This means that there is no need to 

Any ideas?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.amavis.org/pipermail/amavis-users/attachments/20130826/8c3956f8/attachment.html>

More information about the amavis-users mailing list