lost connection with

gedir.goncalves at bndes.gov.br gedir.goncalves at bndes.gov.br
Thu Oct 20 20:09:08 CEST 2011


My problem is PERL or SpamAssassin.

I tried to use spamc command line and received an error (0/0): 

Command: spamc -c < message
Return: 0/0

-c  Will print score/threshold to stdout (as ints) or 0/0 if there was an

Thanks for your attention



> About my message, I discovery more info:
> I changed (debug) the file /usr/sbin/amavisd: (call_spamassassin)
> ...
>     $which_section = 'SA check';
>     do_log(4,"CALLING SA check");
>     { local($1,$2,$3,$4,$5,$6);  # avoid Perl 5.8.x bug, $1 gets tainted
> do_log(4,"0- ATE AQUI ESTA FUNCIONANDO!!!!!!!!!!!");
>       $per_msg_status = $spamassassin_obj->check($mail_obj);
> do_log(4,"0.1- AQUI NAO ESTA FUNCIONANDO!!!!!!!!!!!");
> 2011-10-19T17:05:02.561695-02:00 vrt0377 amavis[17398]: (17398-01)
>   CALLING SA check
> 2011-10-19T17:05:02.561896-02:00 vrt0377 amavis[17398]: (17398-01)
> 2011-10-19T17:05:04.485360-02:00 vrt0377 postfix/smtp[16438]: 
> to=<gedir.goncalves em bndes.gov.br>, relay=[]:10024,
> delay=2.1, delays=0.09/0/0.02/2, dsn=4.4.2, status=deferred (lost
> connection with[] while sending end of data -- 
> may be sent more than once)
> Any suggestion?

Good job narrowing down the problem!

> I have the following environment:
> PostFix 2.3.
> Amavisd 2.5.1-1
> SpamAssassin 3.2.5.
> SqlGrey 1.7.5-1
> ClamAV 0.97
> Sanitizer 1.76
> Pyzor  noarch  0.5.0-2.el5  epel
> Perl-Razor-Agent-2.85-1.el5.x86_64
> Re2c  0.13.5-1.el5.rf 
> Make  1:3.81-3.el5 
> Gcc  4.1.2-51.el5 
> Policyd-Weight 0.1.15 
> samba.x86_64 
> PERL 5.8.8
> I've tried:
> 1) Disabled in Amavisd.conf
>  # ['asc',  \&do_ascii],
>  # ['uue',  \&do_ascii],
>  # ['hqx',  \&do_ascii],
>  # ['ync',  \&do_ascii],
> 2) Run in  PERL 5.14.2
> 3) Run in Amavis 2.6.6-1

Good. So perl 5.14.2 did not help (which is a useful information).

As you probably still have the offending message in a mail queue, perhaps
the easiest next step would be to enable SpamAssassin debugging
(requires amavisd-new-2.6.0 or later) and see where in SpamAssassin
perl crashes:
  $sa_debug = 'all';

The SpamAssassin log reports are logged by amavisd at log level 3,
at LOG_DEBUG syslog priority, so you need also:
  $log_level = 3;  # (or higher)
and syslog.conf configured not to discard LOG_DEBUG.

Alternatively, extract the message from a queue (postcat) and
try it with a command-line spamassassin. If that fails too, that
would make it even easier to troubleshoot further.
Upgrading SpamAssassin may help.


"O remetente desta mensagem é responsável por seu endereçamento, seu 
conteúdo e seus anexos. Cabe a seus destinatários, inclusive aqueles 
copiados na mensagem, tratá-la adequadamente, com observância da 
legislação em vigor e dos normativos internos do BNDES, quando cabível. 
São proibidas, sem a devida autorização, a sua divulgação, reprodução e 
distribuição. A inobservância das proibições será passível de aplicação de 
sanções cíveis, criminais e disciplinares, quando cabíveis. Se você 
recebeu esta mensagem indevidamente, antes de removê-la de sua caixa 
postal, solicita-se o reenvio ao remetente, informando o ocorrido."

"The sender of this message is responsible for its addressing, contents 
and attachments. The receiver, including those copied in the message, is 
obliged to use it properly, in compliance with the law in effect and the 
BNDES' internal rules, if applicable. It is prohibited to disclose, 
reproduce and distribute e-mail messages without due consent. Failure to 
obey these instructions may give rise to civil, criminal or disciplinary 
measures, if applicable. If you have improperly received this e-mail, we 
kindly request you to forward the message to the sender stating the error 
prior to deleting it from your inbox."

-------------- Pr?xima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://lists.amavis.org/pipermail/amavis-users/attachments/20111020/602a3f91/attachment.html>

More information about the amavis-users mailing list