spam_quarantine_to problem

Nicolas nico_ps at
Wed Feb 29 20:36:54 CET 2012

 Version of Amavis: 2.6.4
Here is an example mail (from mailbox spam user):

From shylaangeles en  Wed Feb 29 14:19:22 2012
Return-Path: <shylaangeles en>
X-Original-To: spam en mtaXX
Delivered-To: spam en mtaXX
Received: from localhost (localhost [])
        by mtaXX (Postfix) with ESMTP id 08EAB80AI3
        for <spam en mtaXX>; Wed, 29 Feb 2012 
X-Envelope-From: <shylaangeles en>
X-Envelope-To: <joe en XXXXX>
X-Envelope-To-Blocked: <joe en XXX>
X-Spam-Flag: YES
X-Spam-Score: 19.461
X-Spam-Level: *******************
X-Spam-Status: Yes, score=19.461 tag=2 tag2=5.31 kill=6.31
        tests=[ALL_TRUSTED=-1, DRUGS_ERECTILE=2.221, DRUG_ED_CAPS=1.023,
        URIBL_DBL_SPAM=1.7, URIBL_JP_SURBL=1.948, URIBL_SBL=0.644,
        URIBL_WS_SURBL=1.659] autolearn=spam
Received: from mtaXX ([])
        by localhost (mtaXX []) (amavisd-new, port 10024)
        with ESMTP id BNXmyCre+d9B for
 <joe en XXX>;
        Wed, 29 Feb 2012
Received: from pp (localhost [])
        by mtaXX (Postfix) with SMTP id 6BF6480A48
        for <joe en XXX>; Wed, 29 Feb 2012
Message-Id: <20120229171911.6BF6480A48 en mtaXX>
Date: Wed, 29 Feb 2012
From: shylaangeles en
To: undisclosed-recipients:;

Note the content of  "To:"not match with X-Envelope-To: (original final recipient)

Thanks in advance.


 From: Mark Martinec <Mark.Martinec+amavis en>
To: amavis-users en 
Sent: Wednesday, February 29, 2012 4:12 PM
Subject: Re: spam_quarantine_to problem

> I installed Amavis on Debian 6.0 .
> I configure $spam_quarantine_to = "spam\@$myhostname"; and the system work
> ok (forward mail) . But, when I view the mailbox of spam, the header "To:"
> is undisclosed-recipients:; not the original. This dificult forwad false
> positive from the spam account mailbox. How set Amavis to preserve
> original header "To:"

This shouldn't be the case. Messages sent to a quarantine keep their orginal
header field "To:" regardless of whether a quarantine is file-based, or sent
with SMTP to some mailbox. I just tried it with versions 2.7.0 and 2.6.6,
both behave as expected.

The "To:" is also preserved when releasing from a quarantine.

Which version of amavisd is that?

Are you sure the "To:" header field existed in the original message?
Just guessing, perhaps you are looking at some other notification message
and not a quarantined message.

------------ pr?xima parte ------------
Se ha borrado un adjunto en formato HTML...
URL: <>

More information about the amavis-users mailing list