amavis crashing in Natty

Gary V mr88talent at
Tue Mar 22 03:33:01 CET 2011

On 3/21/11, Mark Martinecwrote:
>> Mar 14 10:59:03 myserver amavis[13881]: (!)Net::Server:
>> 2011/03/14-10:59:03 Can't connect to TCP port 10024 on [Die
>> Adresse wird bereits verwendet]\n  at line 88 in file
>> /usr/share/perl5/Net/Server/Proto/
> Previous version hasn't stopped yet when a new version is trying to start,
> binding to the same socket.
>> /etc/init.d/amavis force-reload
> So what does a force-reload do?
>   Mark

Just stop/start as far as I can tell:

	$0 stop
	exec $0 start

Note: in this particular sample, check_noncompatible_upgrade is
commented out, which normally it would not be.

The exact same version of amavisd-new on a slightly older Ubuntu
distro does not exhibit this oddity. Looks like Natty will eventually
be the next release.

Gary V

More information about the amavis-users mailing list